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HunterLab Software and Networks 

Local area networks (LANs) are commonplace today for storage of computer files.  In most cases, 
software purchased from HunterLab can be run from a network and/or data files may be stored on or 
backed up to network drives.  Storing database files on a network can be very efficient, as most 
networks are periodically automatically backed up.  Remember, if your files are not automatically 
backed up, you should manually back them up once per week.  Networking tips for HunterLab software 
products are provided below. 

I.  EasyMatch for Coatings 
EasyMatch Coatings may be installed to and run from a network drive.  Simply indicate the desired 
network location during software installation.  Multiple users may access the same program files at the 
same time, but different sensors and databases must be used and the sensor and software key must both 
be connected to the computer from which the software is being accessed. 

Whether the program files are run from a network or from the computer hard drive, the database may be 
stored on the network drive if desired.  This may be accomplished in either of two ways.  First, you may 
designate a network drive as the location for storing the database files upon initial installation of your 
software when shown the following screen during installation. 

 
This will cause all the required database files to be installed to and stored on the network until you 
specifically make a change. 
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Secondly, you may copy an existing database or a newly-installed database to the desired location on a 
network drive and then use the External Database button on the screen obtained by choosing 
Preferences from the Matching menu in EasyMatch and then clicking the Database button. 

 
If you wish to operate the software using a database on the local computer hard drive but back up your 
data files to the network periodically, simply use a file copy program (such as the Windows File 
Manager or Explorer) to copy the data files (all files with the extensions .CDX, .DBF, and .FPT) from 
the hard drive to the network drive whenever desired.  If you should need to restore any lost files, you 
can then simply copy the file(s) back from the network to the computer hard drive. 

II.  EasyMatch OnLine 
EasyMatch OnLine utilizes a client-server architecture, where both the client and server may be installed 
on a single computer or installed on separate computers on the same network domain.  An unlimited 
number of clients may be connected to each server, though only one may be active per instrument 
system (controlling the system) at a time.  The rest of the clients will be passive, observing the run only.  
“Active” or “Passive” may be indicated on the screen accessed by choosing Installation from the 
System menu.  Up to four SpectraProbe XE instruments may be connected to each server and each one 
may use its own active client on that server. 

 
EasyMatch OnLine data may be stored either in job files using the file system or as a job file structure in 
a database (Microsoft Access or SQL).  The data storage type is indicated on the screen that appears by 
choosing System Configuration and then Data Storage from the System menu.  The location for 
storage of the job files or the database is also indicated on this screen and may be any hard drive or 
network drive accessible by the client computer. 
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If the file system method of data storage is being used, job files may also be manually saved to any hard 
drive or network location using the Save Job and Save Job As commands in the File menu, regardless 
of the default file path indicated on the Data Storage screen.  Jobs may also be opened from any location 
using the Open Job command in the File menu. 

If the database method of data storage is being used with the database stored on a network, multiple 
instrument systems and computers may write to and read this database at the same time. 

If you wish to operate the software using a database or jobs on the local computer hard drive but back up 
your data files to the network periodically, simply use Windows Explorer to copy the database or job 
and template files from the hard drive to the network drive whenever desired.  An Access database has 
the extension .MDB.  Jobs and templates have the extensions .JSD and .JTP, respectively.  Follow 
normal SQL Server processes to back up a SQL database.  If you should need to restore any lost files, 
you can then simply copy the file(s) back from the network to the computer hard drive. 

III.  EasyMatch QC 
EasyMatch QC may be installed to and run from a network drive.  Simply perform a “custom” 
installation and indicate the desired network location. 
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The limitation is that only one user may access a single installation at a time, and the sensor and the 
hardware key must both be connected to the computer from which the software is being accessed.  In 
addition, when EasyMatch QC (or any other 32-bit Windows program) is installed, the registry files of 
the computer used for the installation are altered.  Even if the software is installed to and run from a 
network drive, the registry files containing the program preferences will only be located on the hard 
drive of the computer used for installation.  For this reason, it is recommended that EasyMatch QC be 
installed and operated on the same computer. 

Whether the program files are run from a network or from the computer hard drive, the database and 
jobs may be stored on the network drive if desired.  The storage locations sre indicated on the screen that 
appears by choosing System Configuration and then Data Storage from the Options menu.  They may 
be any hard drive or network drive accessible by the computer running EasyMatch QC. 
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Job files may also be manually saved to any hard drive or network location using the Save Job and Save 
Job As commands in the File menu, regardless of the default file path indicated on the Data Storage 
screen.  Jobs may also be opened from any location using the Open Job command in the File menu. 

Multiple computers may write to and read a database contained on a network at the same time.  
Networked jobs may also be opened by multiple computers at the same time, but only the first computer 
that opened the job may write to it. 

If you wish to operate the software using a database and jobs on the local computer hard drive but back 
up your data files and jobs to the network periodically, simply use Windows Explorer to copy the 
database, job, and template files (all files with the extensions .MDB, .JSD, and .JTP) from the hard drive 
to the network drive whenever desired.  An Access database may also be manually backed up using the 
Database/Backup Database command in the File menu or automatically by configuring an automatic 
backup interval on the Data Storage screen shown above.  Follow normal SQL Server processes to back 
up a SQL database.  If you should need to restore any lost files, you can then simply copy the files(s) 
back from the network to the computer hard drive. 

IV.  EasyMatch Textiles 
EasyMatch Textiles may be installed to and run from a network drive.  Simply indicate the desired 
network location during the software installation.  However, only one user may access a single 
installation at a time, and the sensor and the software key must both be connected to the computer from 
which the software is being accessed.  In addition, when EasyMatch Textiles (or any other Windows 95 
program) is installed, the registry files of the computer used for the installation are altered.  Even if the 
software is installed to and run from a network drive, the registry files containing the program 
preferences will only be located on the hard drive of the computer used for installation.  For this reason, 
it is recommended that EasyMatch Textiles be installed and operated on the same computer. 

Whether the program files are run from a network or from the computer hard drive, the database and 
jobs may be stored on the network drive if desired.  First, copy the database and job files to the network 
location desired.  Then, with EasyMatch Textiles running but all jobs closed, access the File menu, then 
choose Default System Settings.  On the screen shown below, fill in the network locations for the 
database and the various types of jobs.  These settings will take effect when you click OK. 
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If you wish to operate the software using a database and jobs on the local computer hard drive but back 
up your data files and jobs to the network periodically, simply use Windows Explorer to copy the data, 
template, and job files (all your files with the extensions .MDB, .JBT, .JBC, and .JOB) from the hard 
drive to the network drive whenever desired.  If you should need to restore any lost files, you can then 
simply copy the file(s) back from the network to the computer hard drive. 

V.  MultiSensor Software 
MultiSensor Software may be installed to and run from a network drive (simply indicate the desired 
network location during software installation).  Multiple users may access the same program files at the 
same time, but different sensors and archives must be used and the sensors must be connected to the 
computer from which the software is being accessed. 

Whether the program files are run from a network or from the computer hard drive, the archive files and 
setup information may be stored on the network drive if desired.  This may be accomplished by 
designating a network drive as the location for installation of the archive and/or setup files on initial 
installation of your software when given the following screens during installation. 
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If you wish to operate the software by storing archives and setups on the local computer hard drive but 
back up your data files to the network periodically, simply use a file copy program (such as Windows 
File Manager or Explorer) to copy the archive and setup files from the hard drive to the network drive 
whenever desired.  These are all the files in the ARCHIVES and PSETUPS subdirectories.  If you 
should need to restore any lost files, you can then simply copy the file(s) back from the network to the 
computer hard drive. 

VI.  SpecWare and Color Analyst 
SpecWare’s installation program automatically installs the software to the C:\ drive of your computer.  
However, if the entire directory of files is then copied to a network drive, it may then be run from that 
drive.  You will need to change to the network drive and directory by typing X:\directory (where X is 
the network drive letter and directory is the SpecWare directory name) from the DOS prompt and 
pressing Enter.  Then type the command to run the program (e.g., for ColorQuest this command is 
CQSPEC) from the network drive.  Only one user may access a single installation at a time, and the 
sensor must be connected to the computer from which the software is being accessed. 

Whether the program files are run from a network or from the computer hard drive, the data files will 
automatically be stored on the local computer hard drive.  If you wish to store and access data files using 
a network, you must use the Data menu (F8) and then choose 7, New Files, to open a new data file at 
the desired location.  Type the drive, directory, and data file name into the New File Name box.  (The 
directory will already need to exist on the network, but the data file will be created, if necessary.)  
Alternately, the data files may be stored on the computer hard drive, but backed up to the network 
periodically, by using the DOS copy command or a file copy program to copy the data files from the 
hard drive to the network drive whenever desired.  Copy all files with the .IDS and .DTA extensions.  If 
you should need to restore any lost files, you can then simply copy the file(s) back from the network to 
the computer hard drive. 

VII.  Universal 
Universal Software may be installed to and run from a network drive.  Simply indicate the desired 
network location during software installation.  Multiple users may access the same program files at the 
same time, but different sensors and databases must be used and the sensor and software key (if required 
by your version) must both be connected to the computer from which the software is being accessed. 

Whether the program files are run from a network or from the computer hard drive, the database may be 
stored on the network drive if desired.  This may be accomplished in one of three ways.  First, you may 
designate a network drive as the location for storing the database files upon initial installation of your 
software when shown the following screen during installation. 
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This will cause all the required database files to be installed to and stored on the network until you 
specifically make a change. 

Secondly, you may copy an existing database or a newly-installed database to the desired location on a 
network drive and then use the Main Database Path field obtained by choosing Preferences from the 
File menu to enter the desired location for the database files. 

 
Lastly, you may use the New Data Base and/or Open Data Base commands in the File menu to create a 
new database at a network location or open an existing database at a network location. 

If you wish to operate the software using a database on the local computer hard drive but back up your 
data files to the network periodically, simply use a file copy program (such as the Windows File 
Manager or Explorer) to copy the data files from the hard drive to the network drive whenever desired.  
Copy all files with the extensions .CDX, .DBF, and .FPT.  If you should need to restore any lost files, 
you can then simply copy the file(s) back from the network to the computer hard drive. 

VIII.  Additional Notes 
Just as two different computers can’t access the same sensor at one time, two different programs cannot 
be used simultaneously to operate the same sensor.  For instance, Universal Software and EasyMatch 
Textiles cannot be run concurrently on the same computer using the same instrument or a 
communications port error will be received for the second program opened. 
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A single installation of a HunterLab program may be accessed from multiple computers using echoing 
software such as PC Anywhere.  This software allows control and viewing of the software and 
instrument from multiple networked terminals at the same time. 

 

For Additional Information Contact: 

Technical Services Department 
Hunter Associates Laboratory, Inc. 
11491 Sunset Hills Road 
Reston, Virginia  20190 
Telephone:  703-471-6870 
FAX:  703-471-4237 
www.hunterlab.com 
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